Flybrix

My Account

General flying

Comments

5 comments

  • Avatar
    Chris Nichols

    Hey Todd!! I am super late to the game, BUT I am having the same problem ( … Did you ever get yours under control, and if so, what did you do?!

    0
    Comment actions Permalink
  • Avatar
    Chris Nichols

    Check your motor connections. After having build these so many times, I still accidentally connect a motor backward now and again. I've found that 99% of the time that I have lift off issues, it's because of my motor connection error. The other thing to try is to take off the minifig to reduce weight for a test flight. The quads have very little head room in terms of weight and motor power. Getting a feel for how the quads fly stripped down as much as possible has been my trick. Let us know if you're still having problems just in case you're having a different problem.

    0
    Comment actions Permalink
  • Avatar
    Chris Nichols

    We are also having trouble getting it to lift off. We have double checked the motor connections and took off the minifig. Any other ideas to try?

    0
    Comment actions Permalink
  • Avatar
    Chris Nichols

    Figured it out you have to make sure the propellers are on the motors correctly.

    0
    Comment actions Permalink
  • Avatar
    Chris Nichols

    yes, usually it's a propeller configuration or a motor connection issue that inhibits liftoff. Now… the question is why?! Do you know the physics behind propeller shapes? ;

    0
    Comment actions Permalink

Please sign in to leave a comment.

Powered by Zendesk